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Copyright and acknowledgments
This guide is for Freeway 4 Pro.

Copyright © 1997-2005 Softpress Systems Ltd. All rights reserved.

The Freeway software and this documentation are copyright materials. 

No part of the Freeway software may be reproduced, transmitted, 

transcribed, stored in a retrieval system, or translated into any language, 

or computer language, in any form or by any means without the prior 

written permission of Softpress Systems Ltd. Additional copies of this 

guide may be made and distributed provided they include this copyright 

notice.

Softpress Systems Ltd specifically retains title to all Freeway computer 

software. The software described in this guide is furnished under 

a license agreement and may only be installed, used, or copied in 

accordance with the terms of that agreement.

Softpress is a trademark of Softpress Systems Ltd in the United States 

and other countries. Freeway is a trademark of Softpress Systems Ltd, 

which may be registered in some countries. 

Apple, Macintosh, Power Macintosh, and the Mac Logo are registered 

trademarks of Apple Computer Inc. All other product names are 

trademarks, or registered trademarks of their respective owners.

Limitation of liability

The information in this guide is believed to be correct as of the date of 

publication. However, our policy is one of continuous development and 

so the information in this guide is subject to change without notice, and 

does not represent a commitment on the part of Softpress Systems Ltd.

This guide was designed and produced by Human-Computer Interface Ltd,  

http://www.interface.co.uk/

Contact details 
You can reach Softpress Systems using the following contact details:

Softpress Systems Ltd 

First Floor 

25 Hanborough House 

Hanborough Business Park 

Witney, Oxon, OX29 8LH 

United Kingdom

Tel: (+44) 1993 882588 

Fax: (+44) 1993 883970

Web: http://www.softpress.com/ 

Email: info@softpress.com

Assumptions and conventions
To avoid ambiguity this guide adopts the following conventions:

Convention What it means

Bold Identifies a name or label that appears on the 

computer screen. For example: Click the OK button.

Computer Identifies text that you key in at the computer 

keyboard.

c, O, C, 

R

Represent the special keys on the keyboard: 

Control, Option (or Alt), Command, and Return.
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About the Freeway documentation
Getting Started with Freeway

The Getting Started with Freeway guide is the ideal place to start learning 

about how to get the most out of Freeway. It includes an overview of 

Freeway’s unique features and benefits, information about planning 

your site and publishing it on the Web, a guided tour of Freeway’s main 

features, and a series of three tutorials showing how to use Freeway to 

create stunning Web sites.

Using Freeway

This Using Freeway guide provides clear step-by-step instructions for 

using all the main features of Freeway, including setting up, previewing, 

and publishing a site, working with pages, text, graphics, tables, and 

forms, and creating dynamic effects. It is designed to help you translate 

your vision into a complete, fully working Web site. 

Freeway Reference

The Freeway Reference guide is aimed at more advanced Freeway users, 

and provides detailed reference information about advanced Web design 

features that may not be needed by all users. It also provides information 

about migrating from existing sites created in other Web programs, and 

a summary of the Freeway preference panels, palettes, and keyboard 

shortcuts. 

On-line Help

Freeway also includes a comprehensive integrated context-linked on-

line help system which you can use to find information about features 

while you are using the product. This includes the same information as 

provided in the Using Freeway and Freeway Reference guides.

The KnowledgeBase

The Softpress Web site also provides an advanced KnowledgeBase 

containing a wide range of information on every aspect of using Freeway, 

including technical notes on specific features, tutorials illustrating how to 

achieve particular effects, answers to frequently asked questions, and 

examples of sites created by third-party designers using Freeway. The 

knowledge base is fully searchable and is being extended on a weekly 

basis to provide answers to any question that users ask about Freeway. 
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This chapter explains how to create a new site, 

either from a template, or by specifying custom 

settings. It also explains how to add pages, 

view the site files in the Site panel, and see the 

structure of the site in the Link Map.
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Creating a new site
Freeway stores all the information about your Web site in a single site 

document.

To create a new site document

• Open the File menu and choose New….

The New Document dialog box is displayed to allow you to specify 

settings that will apply to your entire site.

Either:

• Click the Templates tab to display sets of predefined templates to help 

you create a site in a specific style:

Or:

• Click the Custom tab to specify the settings explicitly for a new blank 

site:

The following table explains the meaning of each of the options: 

Option Description

Default HTML Specifies the default output setting for pages 

in the site. You can override this for individual 

pages at a later stage.

Default page size Specifies the default size, in pixels, for 

new pages in the site. Either choose one of 

the predefined page sizes from the pop-up 

menu, or specify the Width and Height in the 

corresponding fields.

Site folder Allows you to specify the location of the site 

folder, which will contain the site files when you 

publish the site.
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Option Description

Resources Allows you to specify where the graphics and 

other resource files are stored when the site 

is published: Common Resource Folder stores 

all the images in a single folder, Separate 

Resource Folders stores the images in a 

separate folder for each site subfolder, and 

With HTML Files stores the images loose with 

the HTML files.

File names Specifies the format for the file names 

generated by Freeway when the site is 

published, to ensure compatibility with the 

Web server you are going to use for hosting 

your site. Choose Alphanumeric for maximum 

compatibility with old Web servers, DOS for 

MS-DOS Web servers, or UNIX/Windows 

for current Web servers including Mac OS X, 

Windows, and Linux. 

• Click the OK button to create the new site.

If you selected a template you are prompted to save the site. Freeway 

creates a Site Folder to contain the HTML files and resources generated 

when you publish the site, and a Media folder to contain your master 

images and other materials:

Saving files
To save the site

• Open the File menu and choose Save.

The first time you save a custom site the Save dialog box will be 

displayed to allow you to specify a name for the site and the location: 

If you want to save the document as a template:

• Select the Template button.

• Click the Save button to save the document.

Restoring backups
Freeway automatically makes a copy of your document when you do 

your first save after opening it. The backup copy has the same name as 

the original, with the suffix .fwbackup. If for some reason you have a 

problem opening a document file, such as due to a disk fault, you should 

still be able to open the backup file and recover all but your latest work.

To restore a backup file

• Double-click the backup file icon. 

It will be opened as a new untitled document.



S
etting up a site

4



This chapter explains the options for previewing 

your site, either in Freeway or in an external Web 

browser of your choice. It also explains how to 

publish your site, and upload it to your external 

Web space.
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Publishing your site
Publishing your site generates the HTML pages with their associated 

graphics and other resources.

To publish your site 

• Open the File menu and choose Publish Site.

Note that publishing your site automatically replaces any obsolete HTML 

or graphic files in your site folder, so you should not normally edit these 

files manually.

Previewing your site
Previewing your site automatically publishes the site, and then loads the 

current page into a specified Web browser. This allows you to see how 

your content will appear in the Web browser and check your links and 

other active features.

To preview your site in Freeway

• Click the Preview button at the bottom right of the Freeway window:

The current page will be previewed.

To preview your site in a Web browser

• Open the File menu and choose Preview in Browser, then choose the 

Web browser you want to use on the submenu:

Initially the submenu shows Safari, the browser supplied with Mac OS X, 

but you can add other browsers to the submenu using the Browser 

Setup… option as described below.

To add a browser to the Preview submenu

• Open the File menu and choose Preview in Browser, then choose 

Browser Setup… from the submenu.
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The following dialog box shows a list of the browsers you have currently 

selected for previewing, and it allows you to add new browsers or delete 

browsers:

To add a new browser to the menu

• Click the New… button, then locate the browser on your computer and 

click the Open button to add it to the list.

To remove a browser from the menu

• Select the browser and click the Delete button.

To search for all the browsers on your hard disks

• Click the Update button.

To specify the default browser

The default browser is indicated by a checkmark in the Default column.

• Click in the Default column to check the browser you want to use as 

the default.

Uploading your site to a Web server
To make your Web site available on the Internet you need to copy the 

HTML and resource files to a suitable Web server, and this is called 

uploading the site.

The procedure depends on whether you have a Web server that you 

access via FTP, a .Mac account, or a Web server that you access simply 

using file copy.

To upload via FTP

If your Web space is provided by an Internet Service Provider, the most 

usual way of uploading your files to your Web space is via FTP. To do this 

you need to know the server name, directory to contain the files, and 

your log-on user name and password.

• Open the File menu and choose Upload…, then choose FTP from the 

Upload pop-up menu:

• Enter the FTP details in the appropriate fields.

The Directory is optional and can be left blank.

Alternatively leave the User name and Password blank, and Freeway will 

prompt you to enter them each time you upload to the site.
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• Select Passive FTP Mode (PASV) if your ISP requires it, or if upload 

fails without it.

• Leave Save FTP log unchecked unless your ISP has specifically 

requested that you select it.

Occasionally an ISP may require you to enter certain FTP commands to 

access the site, and you can enter these by clicking the Script… button.

• Click the OK button to upload the files via FTP.

To upload your site to a .Mac account

• Open the File menu and choose Upload…, then choose .Mac from the 

Upload pop-up menu:

• Enter your member name and password in the appropriate fields and 

click the OK button to upload the site.

Your site can then be accessed via the address: 

http://homepage.mac.com/myname/

where myname is your .Mac member name.

Note that .Mac assumes that the default page of your site is called 

index.html, so you should make sure that your home page has this 

file name.

Publishing your site on your own 
computer using personal Web sharing
You can use the personal Web sharing built into Mac OS X to host your 

Web site from your own computer. In this case you upload your site using 

file copy.

To turn on personal Web sharing

• Open the Sharing panel in the System Preferences dialog box on your 

computer. 

• In the Services section select Personal Web Sharing:
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To upload files using file copy

• Open the File menu and choose Upload…, then choose File Copy from 

the Upload pop-up menu:

• Click the Select… button and browse to the location where you want 

to upload the site.

If you are using personal Web sharing this will be the Sites folder in your 

home folder. 

You can then access your site using the address:

http://xxx.xxx.xxx.xxx/myname/ 

where xxx.xxx.xxx.xxx is the IP address of your computer, and 

myname is your user name.
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This chapter explains the general design features 

for working in Freeway, including options for 

changing the view, using rulers, guides, and grids, 

aligning items, and the color options.
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Changing the view
When you are working on a site page or master page you can choose 

what scale you work at, and when viewing an enlarged version of your 

page you can pan the page. You can also work with several views on the 

same page.

To change the scale

• Choose the scale from the pop-up Zoom menu at the bottom right of 

the Freeway window:

To specify a precise magnification

• Choose Other… from the Zoom menu.

The following dialog box allows you to specify a scale between 5% and 

1600%:

• Enter the scale and click the OK button to zoom to the specified scale.

To fit the whole page within the Freeway window

• Open the View menu and choose Fit in Window, or choose Fit Page in 

Window from the Zoom menu.

To pan the page area

•Hold down O.

The mouse pointer changes to a grabber hand.

• Drag in the page area with the mouse pointer. 

To work with multiple views

• Open the Window menu and choose New Window to open a new 

window on the same site.

For example, you can work on a close-up of one part of your page while 

seeing an overview of the whole page in a separate window:
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Producing accurate layouts
Freeway provides several features to help you produce consistent layouts 

and align items accurately:

• Rulers along the top and left-hand edges of the page area.

• Ruler guides which you can add to the page to align items accurately.

• Vertical and horizontal grids with a specified interval.

• Margin guides, to create a consistent top and left inset for the page.

The guides and grids help you align objects horizontally or vertically, and 

you can optionally snap objects to the nearest guide or grid. Guides and 

grids do not appear on the page when it is published.

To show or hide the rulers

• Open the View menu and choose Show Rulers or Hide Rulers.

Rulers are displayed by default when you open a new document.

The rulers are calibrated in pixels, and by default the origin is at the top 

left corner of the page.

To change the ruler origin

• Drag from the px symbol at the top left corner where the rulers 

intersect.

Crosswires follow the mouse pointer.

• Drag the crosswires to the new origin:

To reset the ruler origin to the top left corner of the 
page

• Double-click the px indicator where the rulers intersect.

To add guides to the page

• Make sure the rulers are visible; if necessary open the View menu and 

choose Show Rulers.

• Make sure Guides is checked in the View menu; if necessary open the 

View menu and choose Guides.

• Position the mouse pointer over the vertical or horizontal ruler until it 

changes to a drag symbol.
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• Drag the guide to the required position on the page:

To snap to guides or the grid

• Open the View menu and choose Snap to Guides.

When you move the edge of an item near to a guide or grid line it will 

snap to the precise position.

To display guides in front of objects on the page

• Open the View menu and choose Guides Above.

By default guides are displayed behind graphics and other objects on the 

page.

To lock the guides

• Open the View menu and choose Lock Guides.

This prevents you from accidentally moving the guides once you have set 

them up in the correct positions.

To remove a guide

• Drag it and drop it outside the page area.

To display a grid

• Open the Page menu and choose Grids….

The Grids dialog box allows you to define a vertical and horizontal grid 

and apply it either to the current page, or to every page in the document:

• Select Vertical and/or Horizontal to draw a vertical and/or horizontal 

grid.

• In the Width and Height fields specify the spacing between gridlines.

• If you want to add space between pairs of grid lines specify the space 

in the Gutter fields.

• If you want to inset the grid from the top left corner of the page, 

specify the inset in the Left and Top fields.

The Right and Bottom fields will automatically be set to the inset of the 

grid from the bottom right corner of the page.
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• Choose Page from the Apply to menu to apply the grid to the current 

page, or Document to apply it to every page in the site.

• Click the Apply button to preview the grid:

• Click the OK button to use the grid you have defined.

To align items to the grid

• Select one or more items on a page.

• Open the Item menu and choose Align to Grid.

Each item will be moved so that its top and left borders are on the 

nearest gridline.

To define margins

• Open the Page menu and choose Grids….

• In the Margins sections set the Top, Left, Bottom, and Right fields to 

the margins you want to define:

• Choose Page from the Apply to menu to apply the margins to the 

current page or Document to apply them to all pages in the site.

• Click the Apply button to preview the margins:

• Click the OK button to use the margins you have defined.
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To define the color for the guides

• Open the Freeway menu and choose Preferences….

• Click the Grids & Guides icon at the top of the Preferences dialog box 

to display the Grids & Guides options:

• Click the Grid color, Horizontal guide color, Vertical guide color, and 

Margin guide color boxes to define the colors of the corresponding 

guides.

• Click the Link checkbox to keep the horizontal and vertical guides the 

same color.

To define the snap-to distance for the grid and guides

• Open the Freeway menu and choose Preferences….

• Click the Grids & Guides icon at the top of the Preferences dialog box 

to display the grids and guides options.

• Edit the Grid magnetic range and Guide magnetic range to the values 

you want to use:

A recommended value is 5 pixels. 
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Aligning items
You can align two or more items horizontally and/or vertically to achieve 

a consistent layout on the page.

To align items

• Select two or more items on the page.

• Open the Item menu and choose Align….

The Alignment dialog box allows you to specify how you want to align the 

items horizontally and/or vertically:

• In the Horizontal section click the appropriate icon for no horizontal 

alignment, left alignment, center alignment, or right alignment.

• In the Vertical section click the appropriate icon for no vertical 

alignment, top alignment, center alignment, or bottom alignment.

• Click the OK button to align the items.

Working with color
Freeway handles the colors of text, graphics, and other objects in your 

site in a consistent way using the Styles and Colors palette.

Freeway maintains a list of all the colors used in your document, and you 

can give these convenient names, or define your own permanent library 

of colors, to ensure consistency across your Web pages. 

To apply a document color

• Open the Window menu and choose Styles and Colors to display the 

Styles and Colors palette.

• Click the color icon at the top of the Styles and Colors palette to 

display the document colors:

• Select the feature you want to apply the color to from the Apply to 

pop-up menu. 
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The available options will depend on what you have selected, as shown in 

the following table:

Selected What you can change

Nothing Page background color.

HTML item Background or border color.

Table Background or border color.

Graphic item Shadow, glow, background, foreground, or 

border color.

Text in an HTML 

item

Text or text background color.

Text in a graphic 

item

Text, text background, text shadow, text glow, or 

text outline color.

• Click the color you want to apply.

To apply a Web-safe color to an object

This is a set of 216 colors recommended for use on the Web, as they 

are supported in a consistent way on most computers.

• Select the object on your page. 

• Click the Web-safe colors icon at the top of the Styles and Colors 

palette to display the Web-safe colors:

• Select the feature you want to apply the color to from the Apply to 

pop-up menu.

The options will depend on what you have selected.

• Click the color you want to apply.

The new color will be added to the end of the document colors list, with a 

name such as Color 1:
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To apply an arbitrary color to an object

• Click the color options icon at the top right of the Styles and Colors 

palette, and choose Color Picker… from the pop-up menu:

The Color Picker provides five alternative ways of choosing colors.

To add a color to the document colors list

• Click the color options icon at the top right of the Styles and Colors 

palette, and choose New Color… from the pop-up menu.

The Color dialog box allows you to define the new color and give it a 

name:

• Select a color from the Web-safe colors palette, or click the Color 

picker icon in the bottom left corner of Color dialog box and use the 

Color Picker to define an arbitrary color.

• Click the OK button to add the color you have defined to the document 

colors list:
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To edit the document colors

• Click the color options icon at the top right of the Styles and Colors 

palette and choose Edit Colors… from the pop-up menu.

The Edit Colors dialog box shows a list of all the colors in your document 

and allows you to add new colors, import colors from another document, 

or edit the colors:

Built-in colors are identified by a padlock icon in the left column; you 

cannot edit or delete these.

Colors shown in bold are permanent. They will remain in the document 

colors list even if they are not used in the site.

To edit a user-defined color

• Select it in the Edit Colors dialog box and click the Edit… button.

To delete a user-defined color

• Select it in the Edit Colors list, and click the Delete button.

If the color is in use in your site you will be prompted to select a color to 

replace it.

To create a new color

• Click the New… button and follow the method described above for 

adding a new color.

To import the permanent colors from another 
document

• Click the Import… button, locate the other site document, then click 

the Open… button to import its permanent colors into the document 

colors list.



This chapter describes the options for working with 

pages in Freeway, including the procedures for 

creating pages, creating and using master pages, 

linking between pages and within a page, and 

managing links using the Link Map. 
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Creating pages
Each page in your Web site corresponds to a separate page in your 

Freeway document. 

Site pages

In a Freeway document, pages in the site are represented on the screen 

by a black outline with a drop shadow showing the edge of the page. The 

area outside the page is called the pasteboard. You can use this area for 

working, but only items inside the page border will be published to your 

Web pages.

Master pages

Each page in your Freeway document is associated with a master page. 

Items on a master page appear on each page it’s based on.

To create new pages

• Open the Page menu and choose New Pages….

• Enter a title for the page(s) in the New Pages dialog box:

• Enter the number of pages you want to create.

• Select the master page you want to use from the Master pop-up 

menu.

• Click the OK button.

To specify the title and file name

• Click the page icon at the top of the Inspector palette to display the 

general page settings:

• Enter the page title and file name in the Title and File fields.

The home page should normally be named index.html unless you are 

advised otherwise by your ISP. This will be displayed by default when a 

user connects to your site.

To apply a background color to a page

• Click the paintbrush icon at the top of the Inspector palette to display 

the page’s appearance settings.

• If necessary, click the > to expand the Background section of the 

Page panel.

• Choose the color from the Color pop-up menu:

By default, Freeway creates pages that will display in the browser with a 

white background.
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To apply a background image to a page

You can select any GIF, JPEG, or PNG image to be used as the 

background to a page.

Either:

• Drag an image from the Finder or another application and drop it onto 

an empty area of the page, while holding down S.

Or:

• Click the paintbrush icon at the top of the Inspector palette to display 

the page’s appearance settings.

• If necessary, click the > to expand the Background section of the 

Page panel.

• Choose Select… from the Image pop-up menu:

• Select a suitable image and click the Open button.

By default the image will be tiled horizontally and vertically to fill the 

entire browser window but you can choose alternative options using the 

Horizontal and Vertical pop-up menus.

Achieving consistent design with 
master pages
Master pages make it easy to create a series of pages in your site 

with a consistent design. Any items you define on the master page will 

automatically appear on any pages that use that master page.

For example, you might create a master page to define a standard 

header:
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Any pages based on this master page will automatically include the 

header:

You can define any number of master pages in your document to allow 

you to have several different standard page formats in your site, and you 

can choose which master page each page is based on. 

When you create a new page it will initially be a copy of the master page 

it is based on, but you can then modify any of the items or add new 

items as required. 

If you modify one of the items on the master page, the change will 

be reflected on all pages that use that master page, unless you have 

modified that item on the page.

To view the master page for the current page

• Click the Master tab in the bottom right corner of the Freeway window:

Creating master pages
You can either create a new blank master page, or you can create a 

master page from an existing page.

To create a new blank master page

• Open the Page menu and choose New Master….

The following dialog box allows you to specify the new master page:

• Enter a title for the master page.

• Click the OK button.
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To create a master page from the current page

After designing a page you may realize you want to reuse the same 

design on a series of related pages. The easiest way to do this is to 

create a master page from the page.

• Select the page you want to use.

• Open the Page menu and choose Make Master….

The following dialog box allows you to give the master page a title:

• Enter a title for the master page.

• Click the OK button.

A new master page will be created containing the items on the current 

page.

Applying master pages
To apply a different master page to the current page

• Click the page icon at the top of the Inspector palette to display the 

general page settings.

• Choose the master page you want to apply from the Master pop-up 

menu:

To reapply the items from the master page

• Open the Page menu and choose Reapply Master.

Any master items you subsequently modified on the page will remain, and 

copies of the original unmodified items will be copied from the master 

page. You may need to delete the duplicate items you do not require.
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Structuring your site
The Site panel, to the left of the main Freeway window, provides an 

overview of the structure of your site. It provides a convenient way of 

creating pages, master pages, and folders, and allows you to change the 

current page, move pages between folders, or delete pages. 

The top section of the Site panel shows the master pages in your 

document. The lower section shows the structure of folders and pages in 

your Site Folder, with the current page shown highlighted:

To change the current page

• Click the page icon in the Site panel:

To create new pages from the Site panel

• Click the site options icon below the Site panel and choose New 

Pages… from the pop-up menu:

The New Pages dialog box is displayed:

• Enter the Title and number of pages and click the OK button to create 

the pages.

To create a new folder from the Site panel

If your site contains a large number of pages you can divide up the site 

using folders and subfolders to keep related pages together.

When you publish the site, the folder structure will be reflected in the 

structure of the HTML pages generated by Freeway.
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• Open the site options pop-up menu and choose New Folder….

The following dialog box lets you give the new folder a name:

• Enter a name and click the OK button.

It will be added to the bottom of the Site panel:

To rename a page, master page, or folder from the 
Site panel

• Hold down O and click the item.

• Type in the new name:

To delete a page, master page, or folder from the 
Site panel

• Select the item in the Site panel.

You can select multiple pages or master pages by holding down S or 

C as you click:

• Click the – button below the Site panel, or press d.
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To rearrange pages

You can use the Site panel to rearrange the order of the pages in your 

document. Note that this has no effect on how the site is viewed by the 

visitor.

• Drag the page up or down to a new position in the Site panel.

To move a page into a folder

• Drag it below the folder icon in the Site panel:

The page will be indented to show it is contained in the folder:

To create a master page from a page

• In the Site panel drag the page icon and drop it in the master section 

at the top of the palette.

You will be prompted to give the master page a title:

• Click the OK button to create the master page.

Linking to a page
Links, also called hyperlinks, are items on the page, typically sections 

of text or graphics, which act as buttons so that when the user clicks on 

them a different page is loaded into the browser. They allow visitors to 

navigate between pages on your site, within a page, or to other locations 

on the Internet.

To define a graphic as a hyperlink

• Select the graphic item.

• Drag the page you want to link to from the Site panel to the Hyperlink 

field at the bottom of the Freeway window:



W
or

ki
ng

 w
ith

 p
ag

es

29

The graphic will be shown with a link icon, and the name of the page it 

links to will be shown in the Hyperlink field:

To define a selection of text as a hyperlink

• Select the text in an HTML item or graphic item that you want to turn 

into a hyperlink.

• Drag the page you want to link to from the Site panel to the Hyperlink 

field at the bottom of the Freeway window:

If you create a hyperlink from text in an HTML item the text will be 

displayed in the link style, by default underlined in blue.

If you create a hyperlink from text in a graphic item Freeway will 

automatically create an image map positioned over the text.

You can also define links using the Edit Hyperlink dialog box:

• Open the Edit menu and choose Hyperlink…, or click the button to the 

left of the Hyperlink field and choose Other… from the pop-up menu.

For more information about the alternative options see the following 

sections.

Linking within a page
In addition to being able to link to a different page, you can also link to 

a specified location, called an anchor, attached to an item on a page. 

When the user clicks the link, the page is automatically scrolled to the 

position of the item within the browser.

This is useful if you have a long document on a single page, such as a 

list of products organized into categories, and you want to allow the user 

to jump straight to the appropriate category heading in the list.

To create an anchor

• Highlight the text or insert the insertion point cursor where you want to 

create the anchor.

• Open the Edit menu and choose Anchor….
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• In the Define Anchor dialog box enter a name for the anchor and click 

the OK button:

An anchor symbol will be displayed to the left of the text or insertion 

point: 

To create a hyperlink to an anchor

• Open the Edit menu and choose Hyperlink…, or click the button to the 

left of the Hyperlink field and choose Other… from the pop-up menu.

• In the Edit Hyperlink dialog box select Internal, click the page you 

want to link to, and select the anchor name from the Anchor pop-up 

menu:

• Click the OK button.

To specify the target for a hyperlink

Normally when the user clicks on a hyperlink the new page is displayed in 

the same window as the previous page. 

You can also specify that the new page should open in a separate 

window. This is useful if you want the user to be able to get back to the 

previous page easily, such as after displaying a help page. 

• Open the Edit menu and choose Hyperlink….

• Choose _blank from the Target pop-up menu:

The other options are only useful in frame-based pages; see the Freeway 

Reference guide.

To follow a graphic hyperlink

• Select the graphic item containing the hyperlink.

• Open the Edit menu and choose Follow Link….
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To follow an internal text hyperlink

• Select the text in an HTML item or graphic item that has been defined 

as a hyperlink, or position the insertion point somewhere within the 

hyperlinked text.

• Open the Edit menu and choose Follow Link….

The current page in the Freeway document will change to the page linked 

to by the hyperlink.

Linking to other sites
To link to an external address

• In the Edit Hyperlink dialog box click the External tab and type the full 

external address into the URL box:

If you prefer, you can choose the URL prefix by selecting it from the 

Protocol pop-up menu.

To display a list of the external addresses in your 
document

• Open the Edit menu and choose URLs….

The Edit URLs dialog box shows a list of the URLs and allows you to edit, 

check, or delete them:
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Managing links in the link map
To display the link map

• Click the Link Map tab at the bottom right of the Freeway window.

This shows both the internal and external links into the current page on 

the left and out from the current page on the right:

To extend the tree in any direction

• Click the disc icon at the end of a path.

To change the current page on the link map

• Click the appropriate page icon.

To go to the current page

• Double-click its icon on the link map.

Defining the appearance of links
By default, text hyperlinks are displayed underlined in blue, active links 

are displayed underlined in red, and visited links are displayed underlined 

in purple.

Alternatively, for each page in your site you can override the defaults and 

specify how each style of link is displayed.

To define the link colors

• Click the paintbrush icon at the top of the Inspector palette to display 

the page’s appearance settings.

• Click the > to the left of the Links heading to show the link options.

• Choose the color you want for each type of link from the Normal, 

Active, and Visited pop-up menus:

The color of the links will change to reflect the Normal color you have 

specified.

To define the link styles

In addition, if your output option is HTML 4.01 or XHTML you can define 

CSS link styles.

For example, if you want to change the link to red italic when the mouse 

pointer is over it:

• Design the style you want to use; see Working with styles, page 46.



W
or

ki
ng

 w
ith

 p
ag

es

33

• Choose the style from the Hover pop-up menu:

The appearance of the links will change to reflect the Normal style you 

have defined

Defining image maps
When you define a hyperlink for a graphic item, clicking anywhere on the 

graphic will link to the specified page. 

Alternatively you can define an image map, which allows you to draw 

invisible buttons over different parts of the image, and define a separate 

hyperlink for each button. This is useful if you want to create a panel of 

buttons as a single graphic, or allow users to click on different areas of a 

single image, such as a map of the world.

To create an image map

• Draw a graphic item and import an image into it, or drag an image 

onto the page to create a graphic item automatically.

• Click on the Map Area button in the toolbar to display a pop-up menu 

of the map area tools.

• Use the tools to define each of the areas on the graphic that you want 

to make into a hyperlink.

• Define the area as a hyperlink in one of the same ways as for graphics 

hyperlinks:
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The following table explains how to use each of the Map Area tools:

Icon Tool Description

Map Area Drag to draw a square or 

rectangular map area.

Oval Map 

Area
Drag to draw a circular or oval map 

area.

Path Map 

Area

Click at each of the vertices to 

draw a polygonal map area. Click 

and drag to draw a smooth Bezier 

curve. Click again on the last point 

to complete the polygon or curve.

Once you have drawn a map area you can edit it by clicking anywhere 

on the outline to select it, and then dragging any of the points on the 

outline. 

You can also use the rotate tool, skew tool, or mirror (reflect) tool to 

transform a map area.



This chapter describes the options for incorporating 

text into your Web pages using either HTML 

text or graphic text. It explains the differences 

between the two options, and describes how style 

sheets enable you to create named styles to give 

consistency across your site. 
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Options for including text on a Web 
site
There are two options for including text on your Web site: HTML text or 

graphic text.

HTML text

HTML text is the most efficient way of representing text on a Web page, 

and is recommended for the body text. The text is represented as a 

string of characters, with formatting information, and the text is formatted 

and displayed in the browser.

If you don’t include any explicit formatting information with HTML text, 

the browser uses a default font and size to display it. Alternatively you 

can give a list of preferred fonts for displaying the text, called a Font Set, 

in which case the browser will choose the first available font to display 

the text. There is small set of standard fonts that are installed with 

most Web browsers, and you should choose one of these for predictable 

results.

Freeway also allows you to format HTML text using styles defined in a 

Cascading Style Sheet (CSS). This allows you to control a wide range 

of attributes of the text including the style, size, color, baseline shift, 

background color, letter spacing, and word spacing.

Graphic text

Graphic text represents the text as a graphic image on your Web site, 

and is recommended for headings, logos, and other key features of your 

site where you want precise control over the design and appearance. 

With graphic text you can choose any font, style, or size, and because the 

text is sent as a complete graphic to the user’s browser, it will display 

correctly whatever fonts they have installed. You can also apply graphic 

effects to graphic text, including a drop shadow, embossing, outer glow, 

and shape effects.

Representing text as a graphic is less efficient than HTML text, so it 

takes longer to display. Another disadvantage is that graphic text does 

not get indexed by search engines, so users will not be able to search for 

phrases represented as graphic text on your site. 
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Creating text items
To create an HTML item 

• Click the HTML icon in the toolbar:

• Drag to draw a rectangle to hold the text.

The HTML item will be selected to allow you to move it or resize it:

HTML items are identified by a blue border, or a green border if defined 

as a CSS layer item.

To create a graphic item

• Click the Graphic icon in the toolbar:

• Drag to draw a rectangle defining the graphic item:

Graphic items are identified by a gray border.

To type text into an HTML or graphic item

• Double-click the item to position the insertion cursor in the top left 

corner.

• Type the text you want to insert:

If you create text in a graphic item the ascenders and descenders can 

extend beyond the boundary of the graphic item:

In this case Freeway automatically creates a graphic box large enough to 

include the ascenders and descenders.

You can also type text into oval or bezier curved graphic items; for more 

information see Creating graphics, page 55.
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To insert text from a file

• Position the insertion cursor in the item where you want to import the 

text.

• Open the File menu and choose Import Text…:

• Select the text file you want to import and click the Open button to 

insert it.

To move an HTML or graphic item

• Position the mouse pointer within the item.

• Drag the item to the new position with the Select tool.

To copy an HTML or graphic item

• Position the mouse pointer within the item.

• Drag the item to the new position with the Select tool and press O 

before releasing the mouse button.

To resize an HTML or graphic item

• Click the item with the selection tool to display the resize handles on 

its border.

• Drag one of the resize handles to resize the item:

• Hold down S to constrain the size to a square, or SO to keep 

the proportions constant.

To transform a graphic item

• Click one of the transform tools:

• Click the item to display the resize handles on its border.

• Drag one of the resize handles to transform the item:

• When you release the mouse button the text will be redrawn 

transformed:
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You cannot transform an HTML item.

Specifying the appearance of text
You can specify the appearance of text by selecting it and then using the 

options on the Inspector palette. The options available are divided into 

Character settings and Paragraph settings, and depend on whether it is 

HTML text or graphic text, and which version of HTML you are generating.

The options in the Character section apply to the currently selected 

characters, and you can apply different character formatting to different 

characters within a line or paragraph.

The options in the Paragraph section apply to the entire paragraph.

HTML text, HTML 3.2
The fonts are restricted to the standard Web fonts, or predefined font 

sets. Sizes are relative to the default size:

HTML text, HTML 4.0
With HTML 4.0 (or the XHTML options) Freeway takes advantage of CSS 

style sheets to provide additional options, including absolute sizes, and 

indented paragraphs:

Graphic text
With graphic text you can use any of the fonts available on your 

computer, at any size:
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You can also apply a wide range of text effects, using the options on the 

text appearance settings panel of the Inspector palette:

To change the appearance of text

• Select the text you want to change. 

• Select the options as required from the character and paragraph panel 

of the Inspector palette.

To select all the text in an HTML item or graphic item

• Double-click in the item to insert the insertion point in the text, and 

then open the Edit menu and choose Select All.

To create graphic text within an HTML item

If you need text in a distinctive font or style within a block of HTML text, 

you can convert it into graphic text. When you publish the site Freeway 

will convert the section of text into an in-line GIF image.

• Select the text you want to create as a graphic:

• Click the text icon at the top of the Inspector palette to display the 

character and paragraph settings.

• In the Character section choose GIF from the Type pop-up menu to 

convert the selected characters into graphic text:

The formatting options will then change to the options for graphic text, 

and you can specify the settings as required:

To convert a paragraph into graphic text

You can also convert a complete paragraph into graphic text.

• Position the insertion point in the paragraph.

• Click the text icon at the top of the Inspector palette.

• In the Paragraph section choose GIF from the Type pop-up menu to 

convert the entire paragraph into graphic text.
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The formatting options will then change to the options for graphic text, 

and you can specify the settings as required.

Editing text
You can use the standard editing techniques to edit text within an HTML 

item or graphic item, including Cut, Copy, and Paste, selecting, and 

moving the insertion point using the cursor keys.

In addition Freeway provides find and replace, spelling check, and 

automatic hyphenation options.

To find text

• Open the Edit menu and choose Find/Replace, then choose Find… on 

the submenu.

The Find dialog box allows you to specify what you want to look for, and 

where you want to look:

• Set the Range to Document, to search throughout your Freeway 

document, Story to search the item or linked HTML items containing 

the insertion point, or Item to search a single HTML or graphic item.

• In the Find box type the text you want to search for.

By default Freeway searches forwards from the current insertion point.

• Select Backwards to search backwards from the current insertion 

point.

• Select Wrap Around to continue searching from the beginning of the 

range once you have reached the end of the range.

By default Ignore Case is selected, so site and Site are treated as 

equivalent.

• Deselect Ignore Case to search for exactly what you typed.

• Select Words Only to match what you typed only as complete words, 

not within longer words.

To replace text

• Open the Edit menu and choose Find/Replace, then choose 

Replace… from the submenu.

The Replace dialog box includes an additional Replace with field:

• Type the replacement text in the Replace with box.

• Click the Replace button to replace the next occurrence, or the 

Replace All button to replace all occurrences in the specified range 

and direction.
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To continue finding or replacing

• Select Keep Dialog Open to leave the Find or Replace dialog box on 

the screen as you search so you can keep clicking the Find button to 

find further occurrences.

Alternatively open the Edit menu and choose Find/Replace, then choose 

Find Next or Replace Next on the submenu to find or replace the next 

occurrence.

Checking your spelling
Freeway includes a spelling checker which highlights each suspect word 

in the Freeway document, and where possible suggests alternative 

spellings.

To check spelling

• Open the Edit menu and choose Spelling…. 

• Choose Document from the Check pop-up menu to check the entire 

Freeway document, Story to check the item or linked HTML items 

containing the insertion cursor, or Item to check just the currently 

selected HTML or graphic item.

• Click the Start button to start checking.

The most likely suggestion is provided in the Change to box.

Alternatively you can select one of the other suggestions by clicking it in 

the Suggestions list.

• Click the Change button to change the unknown word to the selected 

word.

• Click the Ignore button to ignore the unknown word and continue 

checking.

Change All and Ignore All apply the corresponding option to all 

subsequent occurrences of this word in the document.

• Click the Add button if the unknown word is correct and you want to 

add it to your user dictionary so it will not be flagged in future spelling 

checks.

If you click the Add button in the Spelling dialog box and there is no user 

dictionary selected, the following dialog box will be displayed to allow you 

to select an existing user dictionary or create a new one:

• Click the Open button to open a user dictionary or the Create button 

to create a new one, as described below. 
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To create a user dictionary

You can create a separate user dictionary for each project you are 

working on, and then select the appropriate user dictionary from the User 

dictionary pop-up menu in the Spelling dialog box.

• Click the Options… button in the Spelling dialog box.

The Spelling Options dialog box lists your existing user dictionaries and 

allows you to create a new one:

• Click the New… button to create a new user dictionary.

• Enter an appropriate name for the dictionary and click the Save button:

You can also edit the words in an existing dictionary by selecting it in the 

Spelling Options dialog box and clicking the Edit… button.

Applying effects to graphic text
When you are formatting text in a graphic item, or GIF text in an HTML 

item, Freeway lets you apply a range of powerful text effects including 

a drop shadow, glow, background color, filter effect, outline, and shape 

effect. 

You can combine effects for impressive results, and your text remains 

editable at every stage so you can make changes to the wording of your 

site without needing to manually rework the graphics.

• Click the paintbrush icon at the top of the Inspector palette to display 

the text effect options:

To add a shape effect

• Click > next to the Shape heading to expand the Shape section of the 

Inspector palette.

• Choose the effect from the Shape Effect pop-up menu.

Crack adds random cracks in the characters:
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You can adjust the size, spacing, and depth of the cracks using the 

corresponding sliders:

Wobble adds a random wobble to the outline of the characters:

You can adjust the period, randomness, deviation, and smoothness of 

the wobble using the corresponding sliders:

To add a drop shadow to the text

• Click the Shadow checkbox and click the > to the left of the Shadow 

heading to display the shadow options:

• Choose the color for the drop shadow using the Color pop-up menu, 

and its opacity with the Opacity slider.

• Leave Global checked if you want this drop shadow to use the global 

angle for the page. Changing the Angle then affects all global lighting 

effects. Alternatively uncheck Global to specify the angle for this drop 

shadow independently.

• Specify the angle of illumination by dragging the pointer on the Angle 

control.

• Use the Offset slider to specify the offset for the drop shadow, and 

the Blur slider to blur the drop shadow:
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To add an outer glow

• Select the Glow checkbox and click the > to expand the Glow section 

of the Inspector palette:

• Choose the color for the glow from the Color pop-up menu, and adjust 

its opacity, spread, and blur using the corresponding sliders:

To add a background color to the text

• Select the Background checkbox and click the > to expand the 

Background section of the Inspector palette:

• Choose the color of the background from the Color pop-up menu and 

adjust its opacity using the Opacity slider:

To change the text color

• Click the > next to the Text heading to display the text options:

• Choose the text color from the Color pop-up menu.

• Choose the draw option by clicking the appropriate button: Draw Solid, 

Draw Border Only, or Draw Solid and Thicken. 

For the last two options select the border thickness from the pop-up 

menu.

• Use the Opacity slider to change the opacity of the text:
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• Use the Filter pop-up menu to add an Emboss, Blur, or Scatter effect 

to the text:

 

 

To add an overlay to the text

• Select the Overlay checkbox and click > to expand the Overlay section 

of the Inspector palette:

• Click the button to select the Draw option, and choose a color for the 

overlay from the Color pop-up menu.

Working with styles
Freeway allows you to save a particular combination of text formatting 

settings and give them a memorable name, such as Mainheading. You 

can then apply the same settings to other selections of text simply by 

selecting the style you have defined from the Styles and Colors palette.

Styles provide a convenient way of ensuring consistency throughout your 

Web site by allowing you to apply a predefined group of settings in a 

single operation. In addition, if at a later date you decide to change the 

design of your site, you can simply edit the definition of a style, and any 

text defined with that style will immediately be updated to reflect the 

change.

Attributes
Each style consists of a list of attributes, such as Font, Size, and Align. 

The attributes are divided into CSS attributes and graphic attributes, and 

into character attributes and paragraph attributes.

CSS and graphic attributes
CSS attributes are applied to text in HTML items. Graphic attributes are 

applied to text in graphic items, and GIF text in HTML items.

You can choose which attributes to view by choosing CSS Attributes, 

Graphic Attributes, or CSS and Graphic Attributes from the View pop-up 

menu at the bottom of the Edit Style dialog box.
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When an attribute, such as Font, has different options for CSS text and 

graphic text, the Edit Style dialog box shows two controls to allow you to 

set each option independently:

Character and paragraph attributes
In the Edit Style dialog box the attributes are divided into Character and 

Paragraph sections.

Character attributes can be applied to individual characters in a section 

of text.

Paragraph attributes apply to the whole paragraph, or all characters in the 

paragraph.

In addition, the Graphic Attributes include a Graphic Text Effects section 

listing text effect attributes which can be applied to characters within 

graphic text:

To define a new style

• Click the styles icon at the top of the Styles and Colors palette to 

display the document styles.

• Click the options icon at the top right of the Styles and Colors palette 

and choose New Style… from the pop-up menu:
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The Add Style dialog box will be displayed to allow you to define the new 

style:

• Enter a name for the style in the Name box.

• To specify the HTML tag to be used for text in this style optionally 

enter the tag in the Tag field. 

You can choose a predefined tag from the pop-up menu.

For example, to use one of the standard HTML heading tags enter the 

appropriate tag h1, h2, or h3 in the Tag box. This ensures that visitors to 

your site with older browsers that do not support CSS styles will see the 

text in an appropriate weight of heading.

• To define character formatting for the style click the + to the right of 

the Character heading, then choose the character attribute you want 

to define from the pop-up menu:

A control will be added to the Character section to allow you to set the 

value of the attribute:
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• Repeat for any other character attributes you want to define for the 

style. 

You can remove an attribute by clicking the – to the right of the attribute 

in the Character section of the Add Style dialog box.

• To define paragraph formatting for the style click the + to the right of 

the Paragraph heading and choose the paragraph attribute you want to 

define from the pop-up menu:

A control will be added to the Paragraph section of the Add Style dialog 

box to allow you to set the value of the attribute:

When you have specified the characteristics of the style you want to 

define:

• Click the OK button to define the style. 

The new style will be shown in the document styles panel of the Styles 

and Colors palette. If it includes paragraph formatting a paragraph 

symbol will be shown to the left of the style name:
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To define a style based on existing text

If you have already formatted text using the menus and the options 

in the Inspector palette, you can create a named style based on this 

formatting.

Freeway creates a temporary style for each new combination of 

formatting you define in your site, with a name such as .style1, .style2, 

etc., and these are listed in the Styles panel of the Styles and Colors 

palette below the permanent styles.

• Click the temporary style while holding down c and choose Edit 

Style… from the pop-up menu:

The Edit Style dialog box will be displayed to allow you to edit the 

definition of the style.

• Enter a name for the style and select Permanent to make it a 

permanent style.

• Proceed as for defining a new style above.

To apply a style to text

• Select the text and click the style name in the document styles panel 

of the Styles and Colors palette.

Working with style sheets
Freeway allows you to create multiple style sheets in your document. For 

each page you can then specify which style sheet should be used for the 

text on that page. 

For example, if your site is divided into different sections, each with a 

different theme, you could create a separate style sheet defining the 

styles used in each section.

To manage the styles in your document

Either:

• Open the Edit menu and choose Styles….

Or:

• Click the options icon at the top right of the Styles and Colors palette 

and choose Edit Styles… from the pop-up menu:

The Edit Styles dialog box shows a list of the style sheets, and styles 

within each style sheet, and allows you to edit the definition of individual 

styles.
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To show the styles within a style sheet

• Click > to the left of the style sheet name in the list on the left of the 

Edit Styles dialog box.

Initially there is one style sheet called sheet1, but you can create 

additional style sheets using the options pop-up menu below the list.

To display the definition of a style

• Select the style in the left-hand list.

Its definition will be displayed to the right allowing you to edit attributes, 

add new attributes, or delete attributes:

You can edit, add, or delete attributes in the same way as for adding a 

new style described earlier.

• Click the Select button to display a complete list of all the Character, 

Graphic Text Effect, and Paragraph attributes, from which you can add 

attributes by clicking the corresponding checkboxes:

• Click the Select button again to return to the edit attributes view.

To add a style

• Click the + button below the list, and then specify the attributes of the 

new style to the right in exactly the same way as for creating a new 

style.
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To delete a style

• Select the style in the left-hand list and click the – button.

If the document contains text in the style you are deleting, the following 

dialog box allows you to specify one of the remaining styles to apply to 

that text:

• Select the style you want to use, or [No Style] to leave the text 

without a style, and click the OK button.

To select the style sheet used for a page

• Make sure no items are selected on the page.

• Click the page icon at the top of the Inspector palette to display the 

general page settings.

• Choose the style sheet you want to use from the Style Sheet pop-up 

menu:

When you change style sheets the attributes of any text on the page will 

change to reflect the settings of the matching styles in the new style 

sheet.



This chapter describes the options for working with 

graphics on your Web pages. It explains how to 

import and manipulate graphics, and add effects 

to graphics to create impressive results entirely 

within Freeway.
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Using graphics on your Web pages
Editable graphics

Freeway allows you to import images in a wide range of formats, and 

then manipulate them in Freeway to achieve the exact effect you want. 

You can crop, scale, or transform graphics in a variety of ways and add a 

range of effects to them.

Freeway can import the following file formats as editable graphics:

• GIF (Graphics Interchange Format)

• JPEG (Joint Photographic Experts Group)

• PNG (Portable Network Graphics)

• PICT (a standard Mac graphics Format)

• TIFF (Tagged Image File format)

• Adobe Photoshop (PSD)

• Adobe Illustrator

• PDF (Portable Document Format) 

• BMP (Windows Bitmap)

• EPS (Encapsulated PostScript)

• QDGX (a legacy Mac graphics format) 

• Any format for which you have Photoshop Import/Export plug-ins.

When you publish the site Freeway exports the graphics in one of the 

Web graphic formats: GIF, JPEG, or PNG, optimizing each graphic to 

achieve the best compromise between image quality and download time. 

You can either leave Freeway to select the most appropriate graphics 

format and export settings, or you can manually choose the settings 

individually for each graphic. 

The following table gives the pros and cons of each export format:

Format Pros and cons

GIF Recommended for simple graphics containing a limited 

range of colors, such as diagrams or graphic text.

JPEG Recommended for photographic and other continuous 

tone images.

PNG A recent alternative to GIF, with support for 8-bit 

transparency, but not supported by older browsers.

Pass-through graphics

If you have prepared a series of graphics in an external paint program 

so that they are already optimized for Web display, you can add them to 

the site as pass-through graphics so that they are exported unchanged 

when you publish the site. Pass-through graphics cannot be scaled or 

transformed, or have effects applied to them.

Using plug-ins

You can use Photoshop Import/Export plug-ins to import additional 

file formats into Freeway. Simply put the plug-ins, or an alias to them 

in the Library/Application Support/Freeway 4/PlugIns folder on your 

computer.
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Creating graphics
To create a rectangular graphic item

• Click the Graphic icon in the toolbar:

• Drag to draw a rectangle defining the size and position of the graphic 

item on the page.

The graphic item will be selected, as indicated by the selection handles 

on its border:

To create an oval graphic item

• Click the Oval icon in the toolbar:

• Drag to draw a rectangle defining the size of the oval.

When you import a graphic into the oval graphic item it will be cropped to 

the oval outline:

To create a graphic item with an arbitrary outline

• Click the Path icon in the toolbar:

• Click with the tool to draw successive points on the path, or drag to 

extend handles from the points to create a smooth curve outline.

• Click again on the first point to complete the outline:
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To import a graphic into a graphic item

• Select the graphic item.

• Open the File menu and choose Import….

• Select the image you want to import:

• To import the image as a pass-through graphic select Pass-through.

• Click the Open button to import it.

The image will be shown in the graphic item:

Note: It is good practice to move any images you want to use on your 

site into a Media folder, within your Site folder, before importing them 

into the site. This ensures that you will have the original master versions 

of each image available when you publish the site. If you import images 

from other locations, such as your desktop, there is a risk that they will 

subsequently get moved or deleted, with the result that Freeway will not 

be able to locate them when you next publish the site. 

To drag and drop a graphic

You can simply drag graphics from a Finder window and drop them onto 

your Freeway document.

• Drag the graphic from a Finder window, such as the Media folder. 

• Drop it onto the page in your Freeway document, or into a graphic 

item:

If you drop the graphic into a graphic item it will be cropped to fit the 

item.

If you drop the graphic onto the page, a new graphic item will be created 

the correct size for the graphic you have imported.
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To import a graphic as a pass-through graphic

• Select Pass-through in the Import dialog box and click the Open 

button to import it.

To drag and drop a graphic as a pass-through graphic

• Drag the graphic and drop it onto a page or graphic item, holding down 

O before you release the mouse button.

To import a graphic using a plug-in

If you have appropriate import plug-ins installed, they will appear on the 

Acquire submenu and you can use them to import graphics; see Using 

plug-ins, page 54. For example, with a suitable scanner and plug-in you 

can scan images directly into Freeway.

• Select the graphic item.

• Open the File menu and choose Acquire…, then follow the procedure 

for the plug-in.

The graphic will be imported directly into Freeway. You can manipulate it 

as you would any other imported graphic.

To delete a graphic from a graphic item

• Select the graphic item, then open the Edit menu and choose Clear 

Content.

Alternatively, importing or dragging and dropping another graphic onto the 

same graphic item will replace the original graphic in the item.

Manipulating graphic items
You can manipulate graphic items in a variety of ways, including: resizing, 

cropping, panning, and transforming them.

With pass-through graphics the graphic item needs to be the correct size 

for the graphics. If the graphic item is too small to display the graphic it 

will be displayed as a blue cross and will not be exported when the site 

is published.

To resize a graphic item

• Drag the graphic item by one of its selection handles using the Select 

tool:

When you release the mouse button the graphic will be resized:

You can constrain the graphic item to a square by holding down S, or 

resize the graphic preserving the aspect ratio by holding down S O.

By default, resizing a graphic item does not affect the size and position 

of the graphic it contains. Alternatively, you can specify the resizing 

behavior; see Resizing graphics, page 59.



W
orking w

ith graphics

58

To fit or scale a graphic within the graphic item

• Select the graphic item.

• Open the Item menu, choose Graphic, then choose one of the 

following options from the submenu:

Option Description

Original Size Scales the graphic to the original size.

Fit Box to Graphic Scales the graphic item to fit the current size 

of the graphic.

Center The graphic is centered within the graphic item.

Scale to Box The graphic is scaled to the size of the graphic 

item.

Scale and Pad The graphic is scaled to the size of the graphic 

item keeping its original proportions.

Scale Up The graphic is enlarged by 5% within the 

graphic item.

Scale Down The graphic is reduced by 5% within the graphic 

item.

To position a graphic within the graphic item

• Select the graphic item.

A panning handle is displayed in the middle of the graphic:

• Move the mouse pointer over the panning handle until the pointer 

changes to a grabber hand.

• Drag the graphic to its new position:

To position a graphic numerically

• Select the graphic item.

• Open the Item menu and choose Modify…, or double-click the graphic 

item.

The Graphic dialog box displays information about the graphic.

• Click the Graphic tab and enter the required horizontal and vertical 

offset values:

The offsets are measured from the top left corner of the graphic item.

To transform a graphic item

• Select one of the transform tools:
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• Click the item to display the resize handles on its border.

• Drag one of the resize handles to transform the item:

• When you release the mouse button the item will be redrawn 

transformed:

To transform a graphic item numerically

• Select the graphic item.

• Open the Item menu and choose Transform….

The following dialog box allows you to specify a transform for the item 

and/or its content:

Resizing graphics
For each graphic item you can specify what happens to the content when 

its graphic item is resized. The four options are explained in the following 

table.

Option Example Description Keys

Preserve 

Size

Resizing the graphic item does 

not affect the size or position of 

the graphic it contains.

c

Scale 

Graphic

The graphic is scaled to match 

the graphic item.

C

Scale 

and Pad

The graphic is scaled, and 

padded with space to preserve 

its original aspect ratio.

OC

Scale 

and Trim

The graphic is scaled to fit 

the graphic item, if necessary 

cropping the graphic in one 

dimension to preserve the 

aspect ratio.

O

You can set the resizing behavior permanently for the graphic item as 

described below, or you can set it temporarily while resizing the graphic 

item by holding down the modifier key(s) shown in the Keys column in the 

above table.

To set the resizing behavior 

• Select the graphic item.

• Open the Item menu and choose Modify….

• In the Graphic dialog box click the Graphic tab.
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• Choose the sizing option from the Sizing Behavior pop-up menu:

Adding effects to graphics
Freeway allows you to add a range of effects to graphics including: drop 

shadow, outer glow, background color, foreground color, and border. 

In conjunction with the transformations these effects enable you to 

create complex graphic composites entirely within Freeway, without 

needing to use another paint program, and with the flexibility of being 

able to alter your artwork at any stage.

• Select the graphic item.

• Click the paintbrush icon at the top of the Inspector palette to display 

the item appearance settings:

The individual settings are described in the following sections.

To apply a crack or wobble effect to the graphic

• In the Shape Effect section choose Crack or Wobble from the Effect 

pop-up menu:

   

The Crack effect provides controls to allow you to adjust the period, 

randomness, gap, and depth of the cracks.

The Wobble effect provides controls to allow you to adjust the period, 

randomness, deviation, and smoothness of the wobble:
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To add a drop shadow

• In the Shadow section select the Shadow checkbox:

• Choose the color for the drop shadow using the Color pop-up menu, 

and its opacity with the Opacity slider.

• Leave Global checked if you want this drop shadow to use the global 

angle for the page. Changing the Angle then affects all global lighting 

effects. Alternatively uncheck Global to specify the angle for this drop 

shadow independently.

• Specify the angle of illumination by dragging the pointer on the Angle 

control.

• Use the Offset slider to specify the offset for the drop shadow, and 

the Blur slider to blur the drop shadow:

To add a glow to the graphic

• In the Glow section select the Glow checkbox:

• Choose the color for the glow from the Color pop-up menu.

• Use the Opacity, Spread, and Blur sliders to adjust the characteristics 

of the glow:
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To set the background color

• In the Background section choose the background color from the 

Color pop-up menu:

If the graphic has a transparent background the fill color will show 

through:

To set the foreground color 

• In the Foreground section choose the color from the Color pop-up 

menu:

A graphic item with a foreground color will tint text in a graphic item 

below it:

To add a border around the graphic

• In the Border section select the Border checkbox:

• Choose the color for the border from the Color pop-up menu.

• Specify the thickness of the border using the Size pop-up menu and 

the border dash pattern using the Dash pop-up menu.
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• For solid borders you can specify the position of the border relative to 

the graphic rectangle by choosing Outside, Center, or Inside from the 

Position pop-up menu.

• Add a filter effect to the border by choosing Emboss, Blur, or Scatter 

from the Filter pop-up menu, and use the controls to adjust the filter 

effect.

Combining graphics
If you create two overlapping non-layer graphic items, by default Freeway 

combines them into a single graphic large enough to contain both items 

when you preview or publish the site, as indicated by the blue rectangle 

enclosing the items:

In some situations you may prefer to export overlapping graphics as 

separate graphics. For example, if one graphic contains a photographic 

image and the other contains text, you may want to set the output type 

to JPEG for the image and GIF for the text.

To specify the output settings for combined graphics

• Click the output settings icon at the top of the Inspector palette to 

display the item output settings.

If one or more combined graphics are selected, a separate Combined 

Graphic section shows the output settings for the combined graphics:

To export overlapping graphics separately 

• Select one of the overlapping graphics.

• Click the general settings icon at the top of the Inspector palette to 

display the item general settings.

• In the Properties section uncheck Combine Graphics:

You can now set the output settings for each graphic independently.
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Controlling how graphics are exported
By default Freeway exports graphic items with 256 colors or less in GIF 

format, and with more than 256 colors in JPEG format. However, you can 

specify the export format explicitly for any item and, if required, specify 

the individual parameters determining how the graphic is exported when 

you publish the site.

To set the export options

• Select the graphic item.

• Click the output settings icon at the top of the Inspector palette to 

show the item output settings:

For more information about the export settings for each of the graphics 

formats refer to the Freeway Reference guide.

To specify the alt text

It is good practice to set meaningful alt (or alternative) text for each of 

the graphics on your site. This is displayed to users who choose not to 

display the graphics, and provides information that can help your site get 

indexed by search engines.

By default the alt text is set to the name of the graphic.

• Edit the text in the Inspector palette to specify different alt text:

Using multimedia
Freeway allows you to incorporate movies and animations in a range of 

standard formats, including:

• Movies in QuickTime format, created by applications such as Adobe 

Premiere, Apple Final Cut Pro, and iMovie.

• Animations in Macromedia Shockwave format created using 

applications such as Macromedia Director, Flash, or FreeHand. 

Both formats are widely used on the Web, and although Web browsers 

require plug-ins to display them, most users will already have these 

installed. 
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To import a multimedia file 

Either:

• Drag the file from a Finder window, and drop it onto the page.

An HTML item will be created the correct size for the content. 

Or:

• Click the HTML icon in the toolbar and drag to draw a rectangle.

• With the item still selected, open the File menu and choose Import….

• Select the multimedia file you want to import and click the Open 

button to import it.

If the plug-in content is supported by QuickTime the HTML box will show 

a preview of the content; otherwise it shows a plug-in icon with the 

associated file name:

When the site is published, the file you specified will be copied into your 

site folder.

For each type of content the item output settings panel of the Inspector 

palette allows you to set specific options to determine how the content 

is played. 

To set options for a QuickTime movie

• Select the HTML item containing the movie.

• Click the output settings icon at the top of the Inspector palette to 

display the item output settings:

• Select Autoplay to play the movie automatically when the page is 

loaded.

• Set Loop to No to play the movie once, Yes to loop the movie, or 

Palindrome to play the movie forwards and then in reverse repeatedly.

To display the QuickTime movie controller

• Select Controller on the output settings panel of the Inspector palette.

• Open the Item menu, choose Graphic, then choose Fit Box to Graphic 

from the submenu to make the HTML item the correct size to include 

the controller:
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When the movie is displayed in a Web browser a controller will be 

provided to allow the user to control playback manually:

To set the options for Flash animations

• Select the HTML item containing the Flash animation. 

• Click the output settings icon at the top of the Inspector palette to 

display the item output settings:

• Select Loop to play the animation repeatedly.

• Select Play to play the animation automatically when the page is 

loaded.

• Choose the quality from the Quality pop-up menu.

Managing resources
The Resources dialog box contains a list of all the graphics and other 

content files that are used in the current document. This dialog displays 

information about each individual graphic and allows you to delete, 

update, and resample graphics. You can also define whether a particular 

graphic will be exported when the Web page is published.

To display the resources

• Open the Edit menu and choose Resources…:

The Resources dialog box shows the following information:

Option What it shows

File The file name, with the option of showing the location. 

Use the pop-up menu to display the graphic’s file 

name only, or its full file path.

Type The file type.

Status OK if the graphic is up to date, Missing if the file is 

not present, or Modified if the file is not current.
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Option What it shows

Page The page on which the graphic appears.

Publish Whether the graphic will be exported as part of the 

Web page.

To update all the graphics in the document

• Click the Update All button.

This updates the preview images shown on your Freeway pages for any 

graphics you have modified outside Freeway.

To resample graphics to their current size

• Click the Resample All button.

This redraws the preview images, improving the appearance of any 

graphic items you have scaled or transformed.

To edit, show, or delete a graphic

• Select a graphic from the list and click the Show button to display the 

graphic.

• Select a graphic from the list and click the Edit button to display the 

Graphic File dialog box for that graphic.

• Select a graphic from the list and click the Delete button to delete a 

graphic.

Publish problems
If Freeway cannot locate one or more of the original resource files when 

you publish or preview the site, the following Publish Problems warning is 

displayed:

You can then take one of the following actions:

To provide a graphic if the file has moved

• Click the Edit Resources… button in the Publish Problems dialog box 

to display the Resources dialog box.

The missing graphic will be shown as Missing in the Status column.

• Select the missing file, click the Edit… button, then click the Locate… 

button and locate the file in its new location.

To print a list of the missing graphics as a text file, click the Save… 

button in the Publish Problems dialog box. This is useful if, for example, 

you have to retrieve several missing files from an archive.
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To provide a graphic if the file is permanently lost

• Click the OK button in the Publish Problems dialog box to publish the 

site using the preview image for the missing graphic. This may give 

acceptable quality.

You can export the preview image, using the Export command on the 

File menu, and then link this file to avoid getting the Publish Problems 

warning in future.



This chapter describes the options for creating 

tables within Freeway, editing tables, and 

specifying their appearance.

W
or

ki
ng

 w
ith

 t
ab

le
s



W
orking w

ith tables

70

Creating tables
Tables provide a convenient way of presenting information in a grid of 

regular rows and columns. Each cell in a table can contain text, graphics, 

or a combination of the two.

You can change the width of the rows and columns independently, and 

control the appearance of the table in a variety of ways including the 

thickness of the border between cells, and the color of the table or cell 

backgrounds.

You can choose how information is aligned within each cell, and you can 

merge two or more adjacent cells to create cells which straddle multiple 

rows or columns.

To create a table 

Either:

• Click the Table icon in the toolbar: 

• Drag to draw a rectangle on the page.

Or:

• Open the Insert menu and choose Table….

In either case the following Insert Table dialog box is displayed to allow 

you to specify the number of rows and columns:

• Enter the number of rows and columns, and optionally change the 

Border, Cell spacing, and Cell padding.

These are explained later in the chapter.

• Click the OK button to create the table:

Note that you can add or delete rows or columns at a later date if you 

need to.

To type HTML text into a table cell

• Double-click in the table cell with the selection pointer to position the 

insertion bar in the cell. 

• Type the text into the cell just as you would with an HTML item.
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To import text into a table

You can import tab delimited, comma delimited, or space delimited 

text into a table. The fields will be formatted into successive 

cells, automatically expanding the size of the table if necessary to 

accommodate the items.

• Double-click to position the insertion point in the first cell you want to 

import items into.

• Open the File menu and choose Import Text….

• In the Import dialog box select the delimited text file you want to 

import into the table, and choose the format from the Import pop-up 

menu:

If the table is not large enough to accommodate the data the following 

dialog box will give you the option of expanding it or truncating the data:

• Click the OK button to expand the table, or the Truncate Text button 

to ignore data outside the current size of the table.

Moving and resizing tables
Freeway allows you to move or resize an entire table, or resize individual 

rows or columns.

These operations can be performed either by directly manipulating the 

table, or by editing parameters in the appropriate panel of the Inspector 

palette for the table.

To move a table

• Position the Select tool anywhere within the table until the cursor 

changes to a hollow pointer.

• Drag to move the table to the new position.



W
orking w

ith tables

72

To resize a table

• Point to the border of the table with the Select tool until the cursor 

changes to a hollow pointer, then click to display the table’s selection 

handles.

• Drag the border of the table by one of the selection handles to resize 

it.

• Hold down S to constrain the table to a square, or S O to 

keep the proportions constant.

All the rows and columns in the table will be resized in proportion.

To move or resize a table numerically

• Select the table.

• Click the general settings icon at the top of the Inspector palette to 

display the item general settings.

• In the Dimensions section edit the X, Y, W, and H fields to specify the 

position and size of the table:

Selecting cells
To select one or more cells in a table

• Click the first cell with the Select tool.

The cell will be highlighted with a thick border to indicate that it is 

selected:

If you want to select additional cells:

• Hold down the S key and click the additional cells you want to 

select.

They are indicated by a lighter thick border:

To select an entire row or column

• Move the mouse pointer over the top of the column or the left-hand 

edge of the row until the cursor changes to a small solid arrow:
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• Click to select the entire column or row.

• Hold down S and click again to select an additional column or row.

To select all the cells in the table

• Select one cell as described above.

• Open the Edit menu and choose Select All.

Resizing rows or columns
To resize a row or column

• Using the Select tool, point to the border between two rows or 

columns until the cursor changes to the resizing cursor.

• Drag the border to the new position:

When you release the mouse button the row or column will be resized to 

the size you have specified, adjusting the size of the table to keep the 

size of the other rows and columns unchanged.

If you want to move the border between two rows or columns without 

changing the size of the table:

• Press the C key while you are dragging the border, then release it 

after releasing the mouse button.

Note that if cells contain text they cannot be made smaller than the 

longest line of unbroken text.

To resize rows or columns numerically

• Select one or more cells in the table, as described above.

• Click the table cell icon at the top of the Inspector palette to display 

the table cell settings:

• In the Table Cell section edit the W and H fields to specify the width 

and height of the table cell(s).
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Editing tables
Freeway allows you to add or delete rows or columns, and split or join 

cells to form larger cells that span multiple rows or columns.

To insert rows or columns

• Select the table, or cells within the table.

• Open the Item menu, choose Table, then choose Insert Rows… or 

Insert Columns… from the submenu.

The following dialog box allows you to specify how many rows or columns 

to insert and where to insert them:

• Select Start of Table or End of Table to insert the new rows or 

columns at the start or end of the table.

If you have selected a cell within the table you also have the option of 

inserting new rows or columns before or after the selected cell.

• Select Before Selection to insert the new rows or columns before the 

selected cell, or After Selection to insert them after the selected cell.

• Click the OK button to add the rows or columns you have specified.

To add a row or column by dragging within a table

• Using the Select tool, point to the border between two rows or 

columns until the cursor changes to a resizing cursor.

• Drag the border to indicate the size and position of the new column, 

and while dragging the mouse button press O to create the new 

column.

To delete rows or columns

• Select one or more cells in the table.

• Open the Item menu and choose Table, then choose Delete Row or 

Delete Column from the submenu.

The rows or columns indicated by the cell or cells you have selected will 

be deleted.

Joining and splitting cells
You can combine two or more cells into a single cell that spans multiple 

rows or columns. This is useful to create headings across a table, or 

provide information that applies to several rows or columns in a table:
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To join two or more cells

• Select the cells you want to join, in Selecting cells, page 72.

• Open the Item menu and choose Table, then choose Join Cells from 

the submenu.

The array of cells defined by the cells you selected will be combined into 

a single cell, with the settings and contents of the first cell you selected.

To split a cell

• Select the cell.

• Open the Item menu and choose Table, then choose Split Cells from 

the submenu.

The following dialog box allows you to specify how you want to split the 

cell:

Specifying the appearance of tables
To specify the cell border, spacing, and padding

• Select the table.

• Click the general settings icon at the top of the Inspector palette to 

display the item general settings.

The Cells section shows the number of rows and columns, and the 

border, spacing, and padding settings:

• Edit the parameters as required to determine the appearance of the 

cells:

Parameter What it means

Border The thickness of the border around the outside of 

the entire table.

Cell spacing The thickness of the border between rows and 

columns.

Cell padding The offset between the border and the content of 

each cell.
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To specify the color of a cell

• Select one or more cells.

Either:

• Click the color in the Styles and Colors palette.

Or:

• Click the table cell icon at the top of the Inspector palette to display 

the table cell settings.

• In the Table Cell section choose the color from the Color pop-up menu:

The cell(s) will be colored:

To set a color for the entire table

• Select the table.

Either:

• Click the color you want to use in the Styles and Colors palette.

Or:

• Click the general settings icon at the top of the Inspector palette to 

display the table’s general settings.

• Choose the color from the Background pop-up menu:

The table will be colored:



This chapter describes how to create forms in 

Freeway to allow visitors to your sites to enter 

information and submit it to your server. It 

describes each of the form tools, and explains how 

to define the action of the form. 
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What are forms for?
A form allows a visitor to type information onto a Web page and submit 

it to your server so you can take appropriate action. You can use a form 

to request a user’s name and email address, ask them to vote for their 

favorite item from a list, or allow them to make an on-line order. In each 

case the visitor provides information and then clicks a Submit button to 

submit it.

The information is sent to the server, where it is usually processed by a 

form-processing script. This script typically returns a page to the user’s 

browser that confirms that the information was received successfully.

Using forms

To use a form on your Web site you need to provide a script that will 

handle the information sent back from the completed form. The creation 

of form-processing scripts is outside the scope of this manual, and if you 

are publishing your site through an Internet Service Provider you should 

contact them to see what options are available.

Creating a form
To create a form on your Web page you simply design a form, using the 

form items available from the Freeway toolbar. You then specify what the 

form should do using the Form set-up dialog box. 

To design a form 

• Click and hold the HTML icon in the toolbar to display a pop-up menu 

of tools:

• Select the form tool you want to use.

• Drag to draw a rectangle defining the position and size of the form 

item:

• Click the output icon at the top of the Inspector palette to edit the 

item’s parameters:
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The parameters available depend on the particular form item you have 

created. For more information about each form item see the following 

sections.

Note: You can put form items into a table to create a grid layout.

Button
Allows the user to submit the form, clear the form, or perform some 

other action. 

The following parameters are available:

Parameter What it means

Name The name of the parameter sent to the form script.

Value The label of the button, and the value sent to the 

form script. 

Type Submit creates a button that submits the form. 

Reset creates an optional button that resets the 

form items on the form. Button creates a button 

that can be used to execute a JavaScript command. 

To use a graphic as a submit button

Instead of providing a Submit button on a form you can use a graphic 

item as a submit button.

• Select the graphic item.

• Click the output icon at the top of the Inspector palette to display the 

item output settings.

• Select Submit and enter the value for the button:

When the user clicks the graphic item two parameters will be sent to the 

form script indicating the coordinates of the point where the user clicked; 

for example:

AddToCart.X 35

AddToCart.Y 8
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Checkbox
Allows the visitor to select any from a series of options:

It provides the following parameters: 

Parameter What it means

Name The parameter name used to identify the checkbox 

to the form script. Each checkbox on a form should 

be given a unique name.

Value The value sent to the form script when the control 

is checked.

Text The label for the checkbox.

Checked The default state of the checkbox.

Radio button
Allows the visitor to select one of a number of mutually exclusive options:

Each set of radio buttons is called a ‘cluster‘. Selecting one radio button 

in a cluster automatically deselects all the other buttons in the cluster.

The following parameters are provided:

Parameter What it means

Name The name identifying the cluster of radio buttons, 

and the parameter sent to the form script.

Value The value to identify this radio button. The value of 

the selected radio button will be the value of the 

parameter sent to the form script. Each button in a 

cluster should have a different value.

Text The label for the button.

Checked The default state of the radio button.

Menu/List
Allows the user to select an item from a list of items.

The items can be displayed as a pop-up menu:

This will appear in the browser like this:
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Alternatively the items can be displayed as a scrolling selection list, 

allowing the user to see several options, and optionally select more than 

one option at a time:

This will appear as follows:

The following parameters are provided:

Parameter What it means

Name The name of the parameter sent to the form script.

Size Set this to 1 for a pop-up menu, or greater than 1 

for a scrolling list of items.

Multiple When checked allows multiple items to be 

selected. 

Choice An optional label used to identify a choice in the 

menu or list.

Value The value returned to the form script if the user 

selects this choice. If no value is specified the 

name of the choice is returned.

Initially 

selected

Identifies one or more values that should be initially 

selected by default.

To add a choice to a pop-up menu or list

• Click the New item icon at the bottom left of the Inspector palette:

The Edit Choice dialog box allows you to specify the choice, value, and 

indicate whether the choice should initially be selected:

• Enter values for the options as required and click the OK button to add 

the choice.

To edit a choice

• Double-click the choice, or select the choice in the list of choices and 

click the Edit item icon:
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To delete a choice

• Select the choice in the choice list and click the Delete item icon:

To change the order of items in the list

• Select an item and click the A or V button to change its position in 

the list.

Text field
Allows the user to enter one line of text.

In most browsers if the user presses R in a text field it submits the 

form.

The following parameters can be specified for a text field:

Parameter What it means

Name The parameter submitted to the form script.

Value A default value that can optionally be displayed in 

the field.

Password Hides the text typed by the user, for password 

fields. 

Maximum 

length

Specifies the maximum number of characters that 

can be entered into the field; for no limit put 0.

Size The width of the field.

Text area
Allows the user to enter multiple lines of text. If necessary, scroll bars 

are displayed to allow the user to scroll through the text they have 

entered.

This will appear as follows:

It provides the following options:

Option What it means

Name The name of the parameter sent to the form script.

Text Optional default text, which will be displayed as the 

initial contents of the field.

Wrap Specifies whether the text should wrap within the 

field. This is normally ignored by browsers. 

Rows, 

Columns
Specifies the dimensions of the field.
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Setting up your form
Once you have designed the form controls on your form you need to 

specify the action to be taken when the user submits the form. 

To define the form action 

• Open the Page menu and choose Form Setup….

The Form Setup dialog box allows you to specify what happens when the 

user submits the form, add hidden fields to the form to pass additional 

information to the server, and add additional code to the form.

• Set the method to POST (the usual option), or GET (a less frequently 

used option that puts the form parameters and values as part of the 

URL).

• In the Action field specify the URL of the script designed to process 

the form.

• In the Encoding field you can optionally specify the form encoding.

• Click the OK button to set up the form.

To specify hidden fields

You can send additional information to the form script in hidden fields, 

which behave just like form controls but are not visible on the form. Each 

hidden field has a name, which is the parameter sent to the form script, 

and the value, which is sent as the parameter’s value.

For example, you might have a questionnaire consisting of several 

questions each with the answers Yes, No, or Don’t know on separate 

pages of your Web site. You could process each question using the same 

form script, and pass the number of the question in a hidden field.

To define a hidden field

• Click the Hidden Fields tab in the Form Setup dialog box.

• Click the New… button to define a new hidden field:
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• Enter a name for the field and its value, and click the OK button to 

save the field.

Note that you should normally choose a unique name for each form 

control or hidden field on your form, so that the value of each item is 

sent to the form script as a separate parameter. If you do give several 

form controls the same name, the parameter will be set to a list of their 

values.
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What actions do
Actions are items that you can add to your Web pages to perform extra 

functions or create dynamic effects. Each action adds special HTML 

or JavaScript instructions to the page to achieve results that would 

normally require sophisticated programming on your part. Here are some 

examples of what actions can do:

Dynamic buttons and text

You can create dynamic buttons that change appearance when the user 

moves the mouse over them in the browser; this is called a rollover. 

Rollovers make the site visually dynamic and give the user useful 

feedback about where to click on the page.

Slave images and layers

The slave image and layer actions allow you to define items on a page 

that are shown or hidden when the user points to a graphic, or clicks a 

button or link. 

Pop-up windows 

A pop-up window can be opened automatically, or when the user clicks 

a graphic, button, or link. Pop-up windows are useful for providing 

subsidiary information relating to the main page.

Animation

The animation actions let you define events that happen automatically 

as the user is viewing the Web page, such as scrolling text, or animated 

graphics.

Navigation

The navigation actions allow you to provide alternative ways of navigating 

around your site instead of standard hyperlinks, including a navigation 

bar, site map, navigation map, and menu bar.

Image effects

Freeway provides a range of image effects that you can apply directly 

to graphics on the site, including blur, sharpen, color, brightness, and 

contrast corrections.

Summary of actions
The following table summarizes all the actions provided with Freeway:

Category Name Type Description

Window Link to New 

Window

Item Displays a pop-up window when 

the user clicks a graphic item.

Pic to New 

Window

Item Displays an image in a pop-up 

window.

Text Link to 

New Window

Object Displays a pop-up window when 

the user clicks a text link.

Pop-up 

Window

Page Displays a pop-up window when 

the page is opened.

Self Closing 

Pop-up 

Window

Page Makes a pop-up window close 

automatically when the user 

browses to another page.

Trigger Blast Timer Page Sends a trigger to an item at a 

specified delay after the page 

is opened.

Random 

Rollover

Item Reveals or hides graphic items 

and sends a random trigger 

when the user points to or 

clicks a graphic item.
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Category Name Type Description

Rollover Item Reveals or hides graphic items 

and sends a trigger when 

the user points to or clicks a 

graphic item.

Random 

Sequence

Page Sends a random sequence 

of triggers after the page is 

opened.

Sequence 

Timer

Page Triggers a sequence of items 

after the page is opened.

Text Rollover Object Triggers an item after the user 

points to or clicks a text link.

Slave Slave Image Item Displays one of up to 20 

images when triggered by 

another action.

Slave Load 

Frame

Page Loads a page into a frame 

when triggered by another 

action.

Slave Show/

Hide Image

Item Shows or hides an image when 

triggered by another action.

Slave Show/

Hide Layer

Item Shows or hides a layer when 

triggered by another action.

Redirection Timed 

Redirect

Page Redirects the user to another 

page after a specified time 

delay.

Version 

Redirect

Page Redirects the user to another 

page depending on the version 

number of their browser.

Layer Move Layer Item Animates a layer.

Category Name Type Description

Other Country List Object Adds a menu of countries to 

a form.

Current Date Object Displays the current date.

Navigation 

Pop-up

Object Allows the user to navigate to 

other pages by selecting them 

from a pop-up menu.

No Cache Page Prevents a page from being 

cached by the browser.

Content Acrobat Object Downloads an Adobe Acrobat 

file when the user clicks a text 

link.

Acrobat Icon Item Downloads an Adobe Acrobat 

file when the user clicks a 

graphic item.

Background 

Sound

Page Plays a sound when the page 

is loaded.

Director Object Embeds a director file in the 

page.

Download 

File

Object Downloads a file when the user 

clicks a text link.

Download 

Icon

Item Downloads a file when the user 

clicks a graphic item.

Flash Extras Item Embeds a Flash movie in the 

page.

QuickTime 

Extras

Item Embeds a QuickTime movie in 

the page.
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Category Name Type Description

Navigation Menu Bar Item Allows you to define a menu 

bar for navigation based on a 

table item.

Navigation 

Bar

Object Automatically creates a 

navigation bar to allow the user 

to navigate to the other pages 

on the site.

Site Map Object Automatically creates a site 

map showing the structure of 

the site and allowing the user 

to navigate to any page.

Navigation 

Map

Item Allows you to convert an HTML 

item into a navigation map.

Buttons Buttons Item Converts a graphic item into a 

button with a 3D appearance.

Graphics Advanced 

Fade

Item Applies a horizontal or vertical 

fade to an image.

Blur Item Blurs an image.

Chroma Key Item Makes specified colors in an 

image transparent to allow 

you to cut it out from its 

background.

Hue Rotate Item Changes the hue of an image.

Impress Item Gives an image an embossed 

appearance.

Linear Blur Item Applies a speed blur to an 

image.

Category Name Type Description

Saturate Item Adjusts the color saturation of 

the image.

Sharpen Item Sharpens the image.

Solarize Item Gives an image the appearance 

of an overexposed or 

underexposed photograph.

Watermark Item Applies a selected graphic to 

an image as a watermark.

Duotone Item Converts the image to a two-

color duotone or three-color 

tritone.

Fade Item Fades the image horizontally or 

vertically.

Fill Master Item Allows you to draw geometric 

shapes with graduated fills and 

borders within a graphic item.

Photo Frame Item Adds a frame effect to an 

image.

Photo Magic Item Provides a variety of image 

adjustments including color, 

brightness, and contrast.

Posterize Item Reduces the number of levels 

in an image.

Scan Lines Item Adds a mesh appearance to an 

image.

The Type column identifies the type of action, which can be Object, Item, 

or Page.
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To add an object action

Either:

• Open the Insert menu, choose Action Item, then choose the action 

from the submenu.

Or:

• Click the Action button in the toolbar, choose the action from the drop-

down menu, then drag to draw an item on the page.

Object actions are shown as an object on your page, and you can move 

or resize the object to determine how it will appear:

To apply an item action

• Select the item.

• Open the Item menu, choose Actions, then choose the action from the 

submenu.

Item actions are applied to a selected item on the page. Most item 

actions can be applied to a graphic item. Some item actions can also be 

applied to other items, such as HTML items or table items.

When an action is applied to an item, the name of the action is displayed 

in the top left corner of the item:

To apply a page action

• Display the appropriate page.

• Open the Page menu, choose Actions, then choose the action from 

the submenu.

Page actions affect the current page in your site. 

The name of the action will be displayed in the top left corner of the 

page:

To apply multiple actions

You can apply multiple actions to a single item or page. The actions will 

be listed in the top left corner of the item:
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The Actions palette shows a tab for each action, and you can click the 

corresponding tab to display or edit the parameters for that action:

To remove an action

• Click the x button to the left of the action’s tab in the Actions palette.

Dynamic buttons and text
Dynamic buttons change appearance when the user moves the mouse 

pointer over them; this is referred to as a rollover. Rollover text is similar, 

and changes appearance when the user moves the mouse pointer over it.

To create rollover buttons

• Create three versions of your button: A normal version, a version to 

be displayed when the user moves the mouse pointer over the button, 

and a version to be displayed when the user clicks the button:

• For convenience give the items appropriate names, such as Normal, 

MouseOver, and Click on the item general settings panel of the 

Inspector palette:

• Select all three items.

• Open the Item menu and choose Align….

• Click the Horizontal center align and Vertical center align icons, and 

click the OK button:

The items will be aligned into a stack with them still selected:

• Open the Item menu, choose Actions, then choose Rollover from the 

submenu.

• Open the Window menu and choose Actions to display the Actions 

palette.
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This allows you to specify which image should be displayed for each of 

the conditions: Normal, MouseOver, and Click.

Initially there is a checkmark against each image in the Normal column, 

so the images are all visible in the normal state.

• Click to remove the checkmark from the Normal column for the 

MouseOver and Click images, and click to add a checkmark in the 

appropriate MouseOver and Click columns for these images:

You can click each column heading to preview the graphic corresponding 

to that state.

You can now preview the effect of your rollover button:

• Click the Preview tab at the bottom right of the Freeway window.

You can also use the Rollover action to trigger slave images; see Slave 

images and layers, page 93.

To create a text rollover

The Text Rollover action can be used to trigger slave effects when the 

mouse moves over a text link. 

• Position the insertion bar in the HTML item where you want to create 

the text rollover:

• Open the Insert menu, choose Action Item, then choose Text Rollover 

from the submenu. 

A text rollover action will be inserted at the insertion point.

• Click outside the HTML item, then click to select the text rollover item:

• Open the Window menu and choose Actions to display the Actions 

palette.

• In the Text field enter the text to be displayed for the rollover.

• Choose Indigo from the Slave Group pop-up menu.
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• Choose the number of the image you want to display from the 

MouseOver # pop-up menu:

You have specified that the rollover action will send trigger 1 to slave 

group Indigo. The next step is to define a slave to be triggered.

A typical use of the text rollover is to display a hidden picture when the 

user moves the mouse pointer over the text.

• Select a graphic item containing a picture.

• Open the Item menu, choose Actions, then choose Slave Image from 

the submenu.

• In the Actions palette uncheck the image in the Normal column, so 

the image is not normally displayed, and check the image in the Image 

1 column, so that it is displayed by trigger 1:

•In the Parameters panel ensure that slave group is set to the same 

slave group as the text rollover, Indigo:

The image will now be displayed when the user moves the mouse pointer 

over the text rollover:

If you also want the text rollover to act as a hyperlink, you can define 

it as a link in the usual way by selecting it and then using the Edit 

Hyperlink dialog box.
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Slave images and layers
The slave actions are actions you can make happen on your Web page, 

such as displaying an image, displaying a layer, or opening a pop-up 

window.

Slave actions are triggered by another action, such as a graphic or text 

rollover.

To show one of several slave images

The Slave Image action allows you to display one of several images 

depending on the trigger number.

For example, you could provide two rollover graphics each of which 

displays a different image:

• Select the graphic item.

• Open the Item menu, choose Actions, then choose Rollover from the 

submenu.

• In the Actions palette click the Parameters button to display the 

Parameters panel.

• Choose an item from the Slave Group menu, and set the MouseOver # 

to 1:

• Select the graphic item containing the image you want to display.

• Open the Item menu and choose Slave Image from the Actions 

submenu.

• In the Actions palette set the Slave Group to the same value as for 

the button, and set Image 1 to Items:
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You can use this technique to define several buttons that display 

different images when the user points to them with the mouse pointer:

To show or hide a slave image

The Slave Show/Hide Image action allows you to display or hide a single 

image in response to a trigger.

• Select the graphic item containing the image.

• Open the Item menu, choose Actions, then choose Slave Show/Hide 

Image from the submenu

• In the Actions palette, set Initially to Hidden if you want the image to 

be revealed by the trigger, or Visible if you want it to be hidden.

• Set the Slave Group to the same slave group as the trigger, and the 

Slave # to the number specified in the trigger action:

Animation
The actions in this section allow you to create dynamic, animated effects 

on your Web pages.

To set up a timed sequence

The Sequence Timer action lets you trigger up to 20 slave actions in 

sequence at a specified speed.

• Open the Page menu, choose Actions, then choose Sequence Timer 

from the submenu.

• In the Actions palette set Loop to Yes to play the sequence repeatedly, 

or No to play the sequence once when the page is opened.

• Choose a group from the Slave Group pop-up menu.

• For each of the triggers you want to use set the corresponding trigger 

item to Yes:

• In the Speed box, specify the delay between triggers in thousandths 

of a second. The default value, 500, gives a delay of half a second 

between triggers.

• Set an appropriate slave action on each of the images; for example, 

Slave Show/Hide Image.

• Preview the page to see the effect of the sequence timer.
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To display a random sequence

The Random Sequence action is identical to the Sequence Timer action, 

except that the triggers are performed in a random sequence.

To trigger several events after a specified delay

The Blast Timer action is similar to the Sequence Timer action, except 

that it triggers up to 20 slave actions simultaneously after a specified 

delay. For example, it can be used to cause several graphics to appear 

on the page simultaneously after a delay of five seconds.

• Open the Page menu and choose Blast Timer from the Actions 

submenu.

• In the Actions palette specify the delay in the Speed box in 

thousandths of a second, and set each of the triggers you want to use 

to Yes:

To animate a layer

The Move Layer action animates an HTML item, graphic item, or table 

defined as a layer. It can be used to add visual interest to a page, and 

the moving object can have other actions, such as a rollover, applied to 

it.

• Select the graphic item. 

• Select the general settings icon at the top of the Inspector palette to 

display the item’s general settings, and select Layer in the Properties 

section:

• Open the Item menu, choose Actions, then choose Move Layer from 

the submenu.

• In the Actions palette specify the following parameters to determine 

how the layer moves:

Parameter Description

Speed The time interval between each movement in 

thousandths of a second.

X The distance the layer moves horizontally, at 

each step, in pixels. Put a negative number to 

move left.

X-Limit The maximum distance moved horizontally, in 

pixels.

Y The distance the layer moves vertically, at each 

step, in pixels. Put a negative number to move 

up.

Y-Limit The maximum distance the layer moves 

vertically, in pixels
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Parameter Description

Loop Set to Yes to repeat the movement or No to 

stop after one movement.

Pop-up windows
This section of actions causes a new window to be displayed above 

the main browser window. Pop-up windows are useful for displaying 

subsidiary information relating to the main page, such as a larger version 

of a graphic. 

Note: You cannot preview the pop-up window actions using Freeway’s 

built-in Preview mode. Instead, open the File menu and choose a 

browser from the Preview in Browser submenu.

To display a new window when the user clicks a 
graphic

The Link to New Window action opens a page in a pop-up window when 

the user clicks a graphic item.

• Create a new page containing the content you want to display in the 

pop-up window.

• Select a graphic item on the original page, or an HTML item with a 

pass-through graphic imported into it.

• Open the Item menu and choose Link to New Window from the 

Actions submenu.

• In the Actions palette specify a name for the window, the page to be 

displayed in the window, the width and height, whether the toolbar and 

scrollbars should be displayed, and whether it should be resizable:

When you click the graphic a pop-up window will be displayed showing the 

content of the window you specified:
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You can use the Self Closing Pop-up Window action to make the window 

close automatically; see To make a pop-up window close automatically, 

page 99.

To define a text link to a pop-up window

The Text Link to New Window action opens a new window when the 

mouse is clicked on a link.

• Create a new page containing the content you want to display in the 

pop-up window.

• Place the insertion point in text in an HTML item on the original page.

• Open the Insert menu and choose Text Link to New Window from the 

Action Item submenu.

• Click outside the HTML item, then click the text link action to select it.

The parameters of the text link action are displayed in the Actions 

palette.

• Select the name of the page you want to display in the pop-up from the 

Page pop-up menu.

The other options allow you to specify whether the window has a toolbar 

and scrollbars, and whether it is resizable:

Setting Use link to Yes allows you to make the text link action into a 

hyperlink, to redirect the user to a different page in the main window as 

well as displaying the pop-up window.

When you click the text link a pop-up window will be displayed:

To display a picture in a pop-up window

The Pic to New Window action is similar to the Link to New Window 

action except that the pop-up window displays a specified image. This is 

useful for allowing the visitor to display a larger version of a graphic on 

the page.

• Select the graphic item containing the original image.

• Open the Item menu and choose Pic to New Window.

• In the Actions palette select the image to be displayed in the pop-up 

window.
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• Specify the width and height of the window, whether the toolbar and 

scrollbars should be displayed, and whether it should be resizable:

When you click the graphic the specified image will be displayed in a pop-

up window:

To display a pop-up window

The Pop-up Window action automatically displays a pop-up window when 

the user browses to a page. This can be used to display an advertising 

message, warning, or provide a navigation tool for use on the site:

• Create a new page containing the content you want to display in the 

pop-up window.

• Switch to the page which you want to display the pop-up window.

• Open the Page menu and choose Pop-up Window from the Actions 

submenu.

• In the Actions palette select the page you have defined for the pop-up 

window, specify the initial position for the pop-up window in the Left 

and Top fields, and the size of the pop-up window in the Width and 

Height fields.

• Use the Toolbar, Scrollbars, and Resizable menus to specify whether 

a toolbar and scrollbars should be displayed, and whether it should be 

resizable.
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• In the Delay field specify the time delay after which the pop-up window 

should be displayed, in seconds.

To make a pop-up window close automatically

• Select the page containing the content to be displayed in the pop-up 

window.

• Open the Page window and choose Self Closing Pop-up Window from 

the Actions submenu.

The action has no parameters but simply causes the pop-up window to be 

closed when the user navigates to a new page in the browser, or closes 

the browser window:

Navigation
The actions in this section provide options for navigating between pages 

in the site.

To perform a timed redirect

The Timed Redirect action simply redirects the user to a different page 

after a specified delay. One use is for a splash page, which displays a 

message to the user and then automatically redirects them to another 

page after a few seconds.

• Open the Page menu and choose Timed Redirect from the Actions 

submenu.

• In the Actions palette choose the page you want to redirect to from 

the Destination pop-up menu, and specify the delay, in seconds, in the 

Delay box:

To set up a version redirect

The Version Redirect action automatically redirects the user to another 

page if their browser is newer than a specified version. For example, 

this allows you to create a home page that supports old browsers, and 

redirect users with newer browsers to a more fully featured version of 

your site.

• Open the Page menu, choose Actions, then choose Version Redirect 

from the submenu. 
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• From the Destination menu choose the page you want to redirect the 

user to, and in the Netscape Vers and IE Vers text boxes specify the 

versions of Netscape and Internet Explorer you want to check for:

The user will be redirected if they have the specified versions or later of 

Netscape or Internet Explorer.

Graphics actions
The graphics actions can be applied to an image in a graphic item 

to adjust its color balance, or apply effects such as sharpen, blur, or 

posterize.

Each of the graphics actions provide an Enabled checkbox:

• Check Enabled to apply the action, and preview its effect on the 

image.

• Uncheck Enabled to disable the action but leave the parameters set 

up so you can apply it at a later time.

To apply image corrections

The Photo Magic graphics action provides a range of image adjustments 

and corrections

• Select the graphic item you want to apply the action to.

• Open the Item menu and choose Photo Magic from the Actions 

submenu.

The Actions palette provides a series of controls to allow you to adjust 

all of the characteristics of the image:

• Use the sliders as appropriate to adjust the characteristics of the 

image.

The Reset button resets the parameters to their defaults.
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A
actions  86

adding  89
animation  86
deleting  90
dynamic buttons  86, 90
dynamic text  86, 90
item action, applying  89
layers  86, 93
multiple actions, applying  89
navigation  86
page action, applying  89
pop-up window  86
rollover  86
slave images  86, 93
text rollover  91

Actions (Item menu)  89

Actions (Page menu)  89

Actions (Window menu)  90

Actions palette  90

Action Item (Insert menu)  89, 97

Add Style dialog box  48

Alt text  64

Anchor… (Edit menu)  29

anchors  29
creating  29
linking to  30

animation  86, 94
layers  95
random sequence  95
timed sequence  94
trigger after delay  95

attributes in styles  46

B
background color

graphics  62
pages  22

background images  23

backup file, restoring  3

border effect, graphic item  62

browsers
adding  6
default, specifying  7
finding  7
removing  7

button, form item  79

C
character attributes  47

character styles  49

checkbox, form item  80

colors
adding to color list  19
creating  20
deleting  20
editing  20
importing  20
web-safe  18

Color dialog box  19

combining graphics  63

conventions  ii

crack effect
graphic item  60
text  43

CSS attributes  46

D
Define Anchor dialog box  30

dictionaries
creating  43
selecting  42

drop shadow effect
graphic item  61
text  44

dynamic buttons and text  86

E
Edit Choice dialog box  81

Edit Style dialog box  50

EPS graphics  54

F
file names  3

alphanumeric  3
DOS  3
UNIX/Windows  3

Find/Replace (Edit menu)  41

Fit Page in Window (Zoom menu)  12

Flash animations  66

forms
actions  83
creating  78
hidden fields  83
setting up  83
using  78

form items
button  79
checkbox  80
menu/list  80
radio button  80
text area  82
text field  82

FTP, uploading files  7
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G
GIF  54

global illumination angle  44, 61

glow effect
graphic item  61
text  45

graphics  54
Alt text  64
blur  86
border  62
brightness  86
color  86
combining  63
contrast correction  86
creating  55
deleting  57
displaying  67
drag and drop  56
edit  67
effects  60
export options  64
formats supported  54
GIF  54
glow  61
hyperlink  28
Illustrator  54
JPEG  54
missing  67
Photoshop  54
PICT  54
plug-ins  57
PNG  54
pop-up window  97
publish problems  67
QDGX  54
resampling  67
resizing  59
shadow  61

graphics (continued)
sharpen  86
show  67
submit button  79
TIFF  54
transforming  57
updating  67
 PDF  54

graphics actions  100

graphic attributes  46

graphic items
copying  38
creating  37, 55
moving  38
oval  55
path outline  55
resizing  38
transforming  38

graphic text  36
converting HTML text  40
effects  43
preferences  39

grids
displaying  14
preferences  16
snap to  14

Grids… (Page menu)  14, 15

Grids dialog box  14

guides
adding  13
locking  14
preferences  16
removing  14
snap-to distance  16
snap to  14

Guides (View menu)  13

H
Hide Rulers (View menu)  13

HTML format, default setting  2

HTML items
copying  38
creating  37
graphic text, creating  40
moving  38
resizing  38

HTML text  36, 39
HTML 3.2 options  39
HTML 4.0 options  39

Hyperlink… (Edit menu)  29

hyperlinks  28
anchors  29
external sites  31
following  30
graphics  28
managing  32
opening a pop-up window  97
preferences  32
specifying target  30
text  29

I
Illustrator graphics, importing  54

image maps  33
creating  33
tools  34

Import/Export plug-ins  54

Import Text… (File menu)  38

J
JPEG  54

JPEG graphics  54



In
de

x

103

L
layers  93

animating  95

links, See hyperlinks

link map  32

Lock Guides (View menu)  14

M
.Mac

uploading files  8

Map Area tools  34

margins
defining  15

master pages  22, 23
applying  25
creating  24
creating from an existing page  25
deleting  27
reapplying items  25
renaming  27

menu/list form item  80

Modify… (Item menu)  59

multimedia  64
Flash animations  66
importing  65
QuickTime movies  65

N
navigation actions  86, 99

timed redirect  99
version redirect  99

New… (File menu)  2

New Document dialog box  2

New Folder dialog box  27

O
Other… (Zoom menu)  12

Oval graphic item tool  55

Oval Map Area tool  34

overlay effect, text  46

P
pages

background color  22
background image  23
converting to master page  25
creating  22
default size  2
deleting  27
linking  28
master pages  22
pasteboard  22
preferences  22
rearranging  28
renaming  27

paragraph attributes  47

paragraph styles  49

pasteboard  22

Path graphic item tool  55

Path Map Area tool  34

personal Web sharing  8

plug-ins
Import/Export  54
importing graphics  57

PNG graphics  54

pop-up windows  86, 96
displaying  98
graphics  97
link  97
self closing  99

Preview in Browser (File menu)  6

publish problems  67

Q
QuickTime movies  65

R
radio button form item  80

Replace dialog box  41

resampling graphics  67

resources, managing  66

Resources… (Edit menu)  66

Resources dialog box  66

rollover actions  86

rollover buttons, creating  90

rulers
resetting the origin  13
showing or hiding  13

S
Save dialog box (File menu)  3

Shockwave animations  64

Show Rulers (View menu)  13

sites
creating  2
designing  11
hosting on your computer  8
linking to  31
previewing in a Web browser  6
previewing in Freeway  6
publishing  6, 8
saving  3
structuring  26
uploading to a Web server  7
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Site folder  2

Site panel  27
deleting items  27
renaming items  27
restructuring site  26

slave images  86, 93
showing or hiding  94

Snap to Guides (View menu)  14

spelling
checking  42
dictionaries, creating  42

styles  46
adding  51
applying  50
attributes  46
character  48
creating from text  50
defining  47
definitions  51
deleting  52
managing  50
paragraph  49
show all  51

Styles and Colors (Window menu)  17

Styles and Colors palette  17

style sheets  50
editing  51
selecting for a page  52

submit button  79

T
Table… (Insert menu)  70

tables
cell spacing  75
color  76
creating  70

tables (continued)
deleting columns  74
deleting rows  74
editing  74
importing text  71
inserting columns  74
inserting rows  74
inserting text  70
joining cells  74
moving  71
properties  75
resizing  72
resizing columns  73
resizing rows  73
selecting cells  72
selecting columns  72
selecting rows  72
splitting cells  74

Table (Item menu)  74

templates
creating  3
selecting  2

text
background  45
blur effect  46
color  45
converting to graphic text  40
crack effect  43
drop shadow effect  44
editing  41
emboss effect  46
finding  41
glow effect  45
graphic text  36
HTML text  36
hyperlink  29
importing  38
opacity  45

text (continued)
overlay effect  46
preferences  39
replacing  41
rollover  91
scatter effect  46
shape  43
spell check  42
wobble effect  44

text area form item  82

text field form item  82

text rollover action  91

Transform dialog box  59

transform tools  58

U
updating graphics  67

Upload… (File menu)  7, 9

uploading files
.Mac account  8
FTP  7
personal Web sharing  9

W
Web-safe colors  18

wobble effect
graphic item  60
text  44
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